Joomla! 3.9.17 Released

Joomla 3.9.17 is now available.

This is a security release for the 3.x series of Joomla which addresses three security vulnerabilities and contains over 40 bug fixes and improvements.

 

What's in 3.9.17?

Joomla 3.9.17 includes 3 security vulnerability fixes and addresses several bugs, including:

Security Issues Fixed

  • Low Priority - Core - Incorrect access control in com_users access level editing function (affecting Joomla 3.8.8 through 3.9.16)
  • Low Priority - Core - Missing checks for the root usergroup in usergroup table (affecting Joomla 2.5.0 through 3.9.16)
  • Low Priority - Core - Incorrect access control in com_users access level deletion function (affecting Joomla 2.5.0 through 3.9.16)

Bug fixes and Improvements

  • Removal of an unneeded file added to 3.9.16 #28307
  • Multilingual Associations: Fix for the Edit Associations buttons in Menu Items #28339 and in Category #28678
  • PHPMailer upgraded to its latest version #28398
  • 'New' MVC classes depreciation notice for 4.0 instead of 5.0 #28366
  • Facilitate the usage of help system by third parties #13286
  • PostgreSQL: Fix for module loading #28278

Visit GitHub for more information about this issue.

Click here for full release information.

We are familiar with the implementation of the upgrade and are currently upgrading multiple sites CONTACT US for a free proposal to update your site.

Joomla Business Support Joomla Hosting Provider Joomla Solutions Developer